The Config Page

The Config page is available only with Professional or Enterprise licensing; the functionality of this page is not available in Sawmill Lite.

Clicking "Options -> Config Options" while in the profile list, or clicking "Config Options" while in the statistics, takes you to the Profile Editor. This provides a graphical interface for editing most aspects of profiles, including the log source, log filters, database fields, and other options.

It is also possible to edit profile options manually using a text editor -- see Power User Techniques for more information.

The Profile Editor is divided into categories; clicking a category name at the left of the screen takes you to that category. The categories are listed below.

Log Source Editor

This provides an editor for the log sources for this profile. A log source specifies the location of log data to analyze in this profile, or the method of acquiring the log data.

Log Filters

Log Filters perform translations, conversions, or selective inclusion ("filter out") operations. For instance, a log filter could be used to reject (exclude) all log entries from a particular IP, or all log entries during a particular time. Log Filters could also be used to convert usernames to full names, or to simplify a field (for instance by chopping off the end of a URL, which is sometimes necessary to analyze a large proxy dataset efficiently).

Log Filters are also used for some log formats (including web log formats) to differentiate "hits" from "page views" based on file extensions. For instance, GIF files are considered "hits" but not "page views", so the default filters set the "hit" field to 1 and the "page view" field to 0 for GIF hits. The same method can be used for any profile, to perform any kind of categorization (e.g. external vs. internal hits for a web log).

Log Filters are written in Salang: The Sawmill Language, which provides full programming language flexibility, including the use of if/then/else clauses, and/or/not expressions, loops, and more.

Reports Editor

This editor lets you create and edit reports which appear in the statistics.

The 'Rebuild Database' Button

This button appears in the "Database/Tools" menu at the top of a profile page. Clicking it rebuilds the database from scratch.

The 'Update Database' Button

This button also appears in the "Database/Tools" menu at the top of a profile page. Clicking it updates the database, by adding any new log data in the log source (data which is in the log source but not in the database).